Pathio Users

Does not get right temp after script

Not sure if this is the right place to post this. But just noticed:

I have a script running for the autobed leveling. It will then heat the nozzle to 140 and bed to 50. After that is complet it should run the temp spesified in the slicer. Nozzle 210 and bed 60.

This does not happend and it starts printing on the start scripts temps. i ll paste the start script under important Slicing Settings below.

  • Formbot Raptor V2:
  • BETA-3:
  • PLA:

Important Slicing Settings:

G90 ; Absolute positioning

M82 ; Extruder absolute mode

M190 S50

M140 S[bed0_temperature] ; Start heating up bed

M104 S140 T0 ; Start heating up nozzle

G92 E0 ; Reset Extruder value

G28 ; Home all axes

G29 ; Probe bed

M104 S[extruder0_temperature]

M190 S[bed0_temperature]

M109 S[extruder0_temperature]

G1 X002 Y002 F4800; move to corner

G1 Z0.2; set z-position for wipeline

G1 Y60.0 E9.0 F1000.0 ; intro line

G1 Y100.0 E12.5 F1000.0 ; intro line

G92 E0.0; reset extruder origin

Hey Azzarin,
I haven’t had this problem myself.
Could you upload the start of the actual gcode that was generated?

Yes i can see the temp is set to 160.
Not sure where it gets that temp from. i guess thats idle temp ?
When starting the print i could not see it go over 140. When using S3D it wont start the print after the bed leveling before the correct temp. in this example 210.

;START_OF_HEADER
;HEADER_VERSION:0.1
;FLAVOR:Griffin
;GENERATOR.NAME:PATHIO
;GENERATOR.VERSION:0.0.2
;GENERATOR.BUILD_DATE:2019-02-18
;TARGET_MACHINE.NAME:Generic/Custom
;EXTRUDER_TRAIN.0.INITIAL_TEMPERATURE:160
;EXTRUDER_TRAIN.0.MATERIAL.VOLUME_USED:52555
;EXTRUDER_TRAIN.0.NOZZLE.DIAMETER:0.40
;BUILD_PLATE.INITIAL_TEMPERATURE:60
;PRINT.TIME:13056
;PRINT.SIZE.MIN.X:150
;PRINT.SIZE.MIN.Y:150
;PRINT.SIZE.MIN.Z:0
;PRINT.SIZE.MAX.X:250
;PRINT.SIZE.MAX.Y:250
;PRINT.SIZE.MAX.Z:30
;END_OF_HEADER
;Generated by PATHIO
; Date: 2019-02-18
; Time: 14-45-19 UTC
; Options: To be continued
; FS CONFIG SETTINGS:

Hey Azzarin,
I think the problem is your variable names, try using “bed_temp” and “nozzle_temp_0”. The full list of variables can be found at https://docs.pathio.xyz/pathio/latest/features/scripting.html

You mean like this: ( i ll try that )

G90 ; Absolute positioning
M82 ; Extruder absolute mode
M190 S50
M140 S[bed_temp_0] ; Start heating up bed
M104 S140 T0 ; Start heating up nozzle
G92 E0 ; Reset Extruder value
G28 ; Home all axes
G29 ; Probe bed
M104 S[nozzle_temp_0]
M190 S[bed_temp_0]
M109 S[nozzle_temp_0]

Yes exactly :slight_smile:

Still running on 140 / 50. Was sure we had it there :slight_smile:

Can you upload the gcode file?

Sorry im an new user and cannot upload attachments. ( to bad )

But when i slice it i see an error. looks like bed_temp_0 is not an option. and as your documentation says. it will skip all other code in the script when it sees an error.

Ohhh I missed that in your last message, I think it should be “bed_temp” without the 0.

1 Like

Yeah i changed that and it works. I guess it only reads bed temp from gcode. and thats fine.

And thank you!

looks like this now:

G90 ; Absolute positioning
M82 ; Extruder absolute mode
M190 S50
M140 S{{ bed_temp }} ; Start heating up bed: uses tmp from gcode
M104 S140 T0 ; Start heating up nozzle
G92 E0 ; Reset Extruder value
G28 ; Home all axes
G29 ; Probe bed
M104 S{{ nozzle_temp_0 }} ; Preheat Tool 0
M190 S{{ bed_temp }} ;
M109 S{{ nozzle_temp_0 }} ; wait for nozzle_temp
1 Like