Pathio Users

Error in the first layer

Geeetech A30 firmware: Smartto
Pathio Version: V0.5.1-beta4 **
PLA

Important Slicing Settings:
When starting the program you have selected a generic printer since the geeetech A30 is not within the options, neither the firmware Smartto and I have selected marlin and in GCode flavor Griffin after configuring it I have saved the gcode.
when I open it in repetier-host it looks perfect, as a rule I heat the hot bed and the extruder (Bowden system) released the impression and the mouthpiece does not touch the warm bed. Before each impression, I level the base. But when it starts printing the nozzle is more raised and does not print.
The same has happened to someone and how has it been solved.
I do not know what parameter I have to modify so that the mouthpiece is not raised anymore.
Thank you.

This sounds like a printer issue, not a slicing issue, to me. Try watching this youtube video from Maker’s Muse, regarding this.

You may also want to include a the Gcode file that you are trying to print; others can look at it and tell if the Z axis coordinates are correct for the first layer height.

1 Like

I have been testing with the same piece using slicer and the first layer has been printed without problems.

These are the first lines of the Gcode:
;START_OF_HEADER
;HEADER_VERSION:0.1
;FLAVOR:Griffin
;GENERATOR.NAME:PATHIO
;GENERATOR.VERSION:0.0.2
;GENERATOR.BUILD_DATE:2019-03-15
;TARGET_MACHINE.NAME:Generic/Custom
;EXTRUDER_TRAIN.0.INITIAL_TEMPERATURE:200
;EXTRUDER_TRAIN.0.MATERIAL.VOLUME_USED:24976
;EXTRUDER_TRAIN.0.NOZZLE.DIAMETER:0.40
;BUILD_PLATE.INITIAL_TEMPERATURE:70
;PRINT.TIME:5552
;PRINT.SIZE.MIN.X:42
;PRINT.SIZE.MIN.Y:41
;PRINT.SIZE.MIN.Z:0
;PRINT.SIZE.MAX.X:116
;PRINT.SIZE.MAX.Y:73
;PRINT.SIZE.MAX.Z:36
;END_OF_HEADER
;Generated by PATHIO
; Date: 2019-03-15
; Time: 10-40-24 UTC
; Options: To be continued
; FS CONFIG SETTINGS:
;{“children”:{“Group 1”:{“children”:{“barrera 3”:{“children”:{},“config”:{“bedAdhesion”:{“brimLayers”:null,“brimTracks”:null,“generateBrim”:null,“generateRaft”:null,“innerEdgesBrim”:null,“raftBaseLayers”:null,“raftBaseTrackThickness”:null,“raftBaseTrackWidth”:null,“raftGap”:null,“raftOffset”:null,“raftTopLayers”:null,“raftTopTrackThickness”:null,“raftTopTrackWidth”:null},“developer”:{“adjacentPointsTolerance”:null,“debugGCodeOutputFolder”:null,“displayInformation”:null,“ellipseSegmentTolerance”:null,“firstSliceTrackExtrusionMultiplier”:null,“generatorName”:null,“generatorVersion”:null,“headerVersion”:null,“infillDeterminationTolerancePercentage”:null,“maxPolygonHoleRepairDistance”:null,“reduceFineDetailPointsTolerance”:null,“reduceInlinePointsTolerance”:null,“shallowSlopeDetectionAngle”:null,“shellGapFillingExtensionDistance”:null,“trackSpiralJoinRadius”:null,“trackSpiralShiftAmount”:null,“trackZigzagJoinRadius”:null,“useRegionBasedSolidFillTracks”:null,“zeroAreaLengthTolerance”:null,“zeroAreaTolerance”:null,“zeroAreaTriangleTolerance”:null},“gCode”:{“enableGCodeRepetition”:null,“firmware”:null,“flavor”:null,“g10retract”:null,“gcodePrecision”:null,“targetMachineName”:null},“infill”:{“infillAngle”:null,“infillCrosshatchFactor”:null,“infillLayers”:null,“infillPercentage”:null,“infillRotationPerSlice”:null,“infillTrackWidth”:null},“materials”:{“infillExtruder”:null,“perimeterFillExtruder”:null,“perimeterInnerExtruder”:null,“perimeterOuterExtruder”:null,“raftExtruder”:null,“skirtExtruder”:null,“supportExtruder”:null},“model”:{“displayName”:null,“modelFile”:“C:\Users\david\iCloudDrive\shapr3D\barrera lego\para geeA30\barrera 3.stl”,“pathInvalid”:null,“uiColourLabel”:null},“nozzlePriming”:{“enablePrimePillar”:null,“generateSkirt”:null,“primePillarInnerRadius”:null,“primePillarPerimeters”:null,“skirtOffset”:null,“skirtTracks”:null},“quality”:{“coastDistance”:null,“enableRetraction”:null,“enableZHop”:null,“extraUnretractionDistance”:null,“extrudeRateMultiplier”:null,“firstSliceHeightMultiplier”:null,“retractionDistance”:null,“retractionSpeed_mm_per_second”:null,“trackThickness”:null,“trackWidth”:null,“travelDistanceBeforeRetracting”:null,“travelDistanceBeforeZHopping”:null,“unretractionSpeed_mm_per_second”:null,“zHopDistance”:null},“shell”:{“ShellFillPerimeterOverlap”:null,“concentricSolidFill”:null,“dynamicTrackingOverPrintPercentage”:null,“enableDynamicTracking”:null,“enableVaseMode”:null,“horizontalShellThickness”:null,“minimumDynamicTrackLength”:null,“minimumGapAreaToProcess”:null,“numberOfVaseBottomLayers”:null,“perimeterStartPoint”:null,“shellThickness”:null,“solidFillAngle”:null,“solidFillRotationPerSlice”:null,“spiralPerimeterTracks”:null,“trackInsideToOut”:null,“trackWidthMax”:null,“trackWidthMin”:null,“useDifferentHorizontalThickness”:null},“speeds”:{“brimFeedRate_mm_per_second”:null,“defaultFeedRate_mm_per_second”:null,“externalPerimetersFeedRate_mm_per_second”:null,“firstLayerFeedRate_mm_per_second”:null,“infillFeedRate_mm_per_second”:null,“internalPerimetersFeedRate_mm_per_second”:null,“raftBaseFeedRate_mm_per_second”:null,“raftTopFeedRate_mm_per_second”:null,“shellFillFeedRate_mm_per_second”:null,“skirtFeedRate_mm_per_second”:null,“supportInterfaceFeedRate_mm_per_second”:null,“supportStructureFeedRate_mm_per_second”:null,“travelFeedRate_mm_per_second”:null},“support”:{“dotExtrusionMultiplier”:null,“dotHeight”:null,“dotSpacing”:null,“dotSpacingRandomness”:null,“dotWidth”:null,“generateSupport”:null,“interfaceGap”:null,“maxUnsupportedOverhangAngle”:null,“minimumSupportedArea”:null,“modelSupportXYSeparationDistance”:null,“numberOfInterfaceLayers”:null,“perimeterInterfaceStrategy”:null,“scanlineDotPattern”:null,“solidBottomLayer”:null,“solidFillInterfaceStrategy”:null,“soluble”:null,“supportCrosshatchFactor”:null,“supportExpansionDistance”:null,“supportFillPercentage”:null,“supportInterfaceFillPercentage”:null,“supportRelAngle”:null,“supportTrackWidth”:null,“useScanlineBasedDottingAlgorithm”:null},“temperatures”:{“automaticBedTemperatureControl”:null,“automaticFanControl”:null,“automaticNozzleTemperatureControl”:null,“bridgingFanSpeedPercentage”:null,“buildPlateTemperature”:null,“defaultFanSpeedPercentage”:null,“fanOnDelay”:null,“idleNozzleTemperature”:null,“maxFanSpeed”:null,“nozzleTemperatures”:null,“overhangFanSpeedPercentage”:null,“supportingFanSpeedPercentage”:null},“transform”:{“postSliceTranslate”:{“x”:78.2,“y”:57.0,“z”:0.0},“postSliceZRotation”:null,“preSliceRotation”:{“x”:0.0,“y”:0.0,“z”:-90.0},“preSliceScale”:null}}}},“config”:{“bedAdhesion”:{“brimLayers”:null,“brimTracks”:null,“generateBrim”:null,“generateRaft”:null,“innerEdgesBrim”:null,“raftBaseLayers”:null,“raftBaseTrackThickness”:null,“raftBaseTrackWidth”:null,“raftGap”:null,“raftOffset”:null,“raftTopLayers”:null,“raftTopTrackThickness”:null,“raftTopTrackWidth”:null},“developer”:{“adjacentPointsTolerance”:null,“debugGCodeOutputFolder”:null,“displayInformation”:null,“ellipseSegmentTolerance”:null,“firstSliceTrackExtrusionMultiplier”:null,“generatorName”:null,“generatorVersion”:null,“headerVersion”:null,“infillDeterminationTolerancePercentage”:null,“maxPolygonHoleRepairDistance”:null,“reduceFineDetailPointsTolerance”:null,“reduceInlinePointsTolerance”:null,“shallowSlopeDetectionAngle”:null,“shellGapFillingExtensionDistance”:null,“trackSpiralJoinRadius”:null,“trackSpiralShiftAmount”:null,“trackZigzagJoinRadius”:null,“useRegionBasedSolidFillTracks”:null,“zeroAreaLengthTolerance”:null,“zeroAreaTolerance”:null,“zeroAreaTriangleTolerance”:null},“gCode”:{“enableGCodeRepetition”:null,“firmware”:null,“flavor”:null,“g10retract”:null,“gcodePrecision”:null,“targetMachineName”:null},“infill”:{“infillAngle”:null,“infillCrosshatchFactor”:null,“infillLayers”:null,“infillPercentage”:null,“infillRotationPerSlice”:null,“infillTrackWidth”:null},“materials”:{“infillExtruder”:null,“perimeterFillExtruder”:null,“perimeterInnerExtruder”:null,“perimeterOuterExtruder”:null,“raftExtruder”:null,“skirtExtruder”:null,“supportExtruder”:null},“model”:{“displayName”:null,“modelFile”:null,“pathInvalid”:null,“uiColourLabel”:"#F5498B"},“nozzlePriming”:{“enablePrimePillar”:null,“generateSkirt”:null,“primePillarInnerRadius”:null,“primePillarPerimeters”:null,“skirtOffset”:null,“skirtTracks”:null},“quality”:{“coastDistance”:null,“enableRetraction”:null,“enableZHop”:null,“extraUnretractionDistance”:null,“extrudeRateMultiplier”:null,“firstSliceHeightMultiplier”:null,“retractionDistance”:null,“retractionSpeed_mm_per_second”:null,“trackThickness”:null,“trackWidth”:null,“travelDistanceBeforeRetracting”:null,“travelDistanceBeforeZHopping”:null,“unretractionSpeed_mm_per_second”:null,“zHopDistance”:null},“shell”:{“ShellFillPerimeterOverlap”:null,“concentricSolidFill”:null,“dynamicTrackingOverPrintPercentage”:null,“enableDynamicTracking”:null,“enableVaseMode”:null,“horizontalShellThickness”:null,“minimumDynamicTrackLength”:null,“minimumGapAreaToProcess”:null,“numberOfVaseBottomLayers”:null,“perimeterStartPoint”:null,“shellThickness”:null,“solidFillAngle”:null,“solidFillRotationPerSlice”:null,“spiralPerimeterTracks”:null,“trackInsideToOut”:null,“trackWidthMax”:null,“trackWidthMin”:null,“useDifferentHorizontalThickness”:null},“speeds”:{“brimFeedRate_mm_per_second”:null,“defaultFeedRate_mm_per_second”:null,“externalPerimetersFeedRate_mm_per_second”:null,“firstLayerFeedRate_mm_per_second”:null,“infillFeedRate_mm_per_second”:null,“internalPerimetersFeedRate_mm_per_second”:null,“raftBaseFeedRate_mm_per_second”:null,“raftTopFeedRate_mm_per_second”:null,“shellFillFeedRate_mm_per_second”:null,“skirtFeedRate_mm_per_second”:null,“supportInterfaceFeedRate_mm_per_second”:null,“supportStructureFeedRate_mm_per_second”:null,“travelFeedRate_mm_per_second”:null},“support”:{“dotExtrusionMultiplier”:null,“dotHeight”:null,“dotSpacing”:null,“dotSpacingRandomness”:null,“dotWidth”:null,“generateSupport”:null,“interfaceGap”:null,“maxUnsupportedOverhangAngle”:null,“minimumSupportedArea”:null,“modelSupportXYSeparationDistance”:null,“numberOfInterfaceLayers”:null,“perimeterInterfaceStrategy”:null,“scanlineDotPattern”:null,“solidBottomLayer”:null,“solidFillInterfaceStrategy”:null,“soluble”:null,“supportCrosshatchFactor”:null,“supportExpansionDistance”:null,“supportFillPercentage”:null,“supportInterfaceFillPercentage”:null,“supportRelAngle”:null,“supportTrackWidth”:null,“useScanlineBasedDottingAlgorithm”:null},“temperatures”:{“automaticBedTemperatureControl”:null,“automaticFanControl”:null,“automaticNozzleTemperatureControl”:null,“bridgingFanSpeedPercentage”:null,“buildPlateTemperature”:null,“defaultFanSpeedPercentage”:null,“fanOnDelay”:null,“idleNozzleTemperature”:null,“maxFanSpeed”:null,“nozzleTemperatures”:null,“overhangFanSpeedPercentage”:null,“supportingFanSpeedPercentage”:null},“transform”:{“postSliceTranslate”:null,“postSliceZRotation”:null,“preSliceRotation”:null,“preSliceScale”:null}}}},“config”:{“bedAdhesion”:{“brimLayers”:1,“brimTracks”:2,“generateBrim”:true,“generateRaft”:false,“innerEdgesBrim”:true,“raftBaseLayers”:3,“raftBaseTrackThickness”:0.28,“raftBaseTrackWidth”:0.3,“raftGap”:0.15,“raftOffset”:0.12,“raftTopLayers”:3,“raftTopTrackThickness”:0.2,“raftTopTrackWidth”:0.3},“developer”:{“adjacentPointsTolerance”:1e-08,“debugGCodeOutputFolder”:"",“displayInformation”:false,“ellipseSegmentTolerance”:0.02,“firstSliceTrackExtrusionMultiplier”:1.05,“generatorName”:“PATHIO”,“generatorVersion”:“0.0.2”,“headerVersion”:“0.1”,“infillDeterminationTolerancePercentage”:1.0,“maxPolygonHoleRepairDistance”:1.0,“reduceFineDetailPointsTolerance”:0.08,“reduceInlinePointsTolerance”:0.02,“shallowSlopeDetectionAngle”:45.0,“shellGapFillingExtensionDistance”:0.01,“trackSpiralJoinRadius”:2.0,“trackSpiralShiftAmount”:0.5,“trackZigzagJoinRadius”:2.0,“useRegionBasedSolidFillTracks”:false,“zeroAreaLengthTolerance”:1e-08,“zeroAreaTolerance”:0.02,“zeroAreaTriangleTolerance”:1e-08},“gCode”:{“enableGCodeRepetition”:false,“firmware”:0,“flavor”:“none”,“g10retract”:false,“gcodePrecision”:2,“targetMachineName”:“Generic/Custom”},“infill”:{“infillAngle”:45.0,“infillCrosshatchFactor”:2,“infillLayers”:1,“infillPercentage”:30.0,“infillRotationPerSlice”:0.0,“infillTrackWidth”:0.3},“materials”:{“infillExtruder”:-1,“perimeterFillExtruder”:-1,“perimeterInnerExtruder”:-1,“perimeterOuterExtruder”:-1,“raftExtruder”:-1,“skirtExtruder”:-1,“supportExtruder”:-1},“model”:{“displayName”:"",“modelFile”:"./test/models/cube.stl",“pathInvalid”:false,“uiColourLabel”:"#55B4E5"},“nozzlePriming”:{“enablePrimePillar”:false,“generateSkirt”:true,“primePillarInnerRadius”:5.0,“primePillarPerimeters”:2,“skirtOffset”:2.0,“skirtTracks”:2},“quality”:{“coastDistance”:0.2,“enableRetraction”:true,“enableZHop”:true,“extraUnretractionDistance”:0.0,“extrudeRateMultiplier”:2.0,“firstSliceHeightMultiplier”:1.0,“retractionDistance”:1.5,“retractionSpeed_mm_per_second”:40.0,“trackThickness”:0.3,“trackWidth”:0.3,“travelDistanceBeforeRetracting”:1.0,“travelDistanceBeforeZHopping”:0.1,“unretractionSpeed_mm_per_second”:40.0,“zHopDistance”:0.1},“shell”:{“ShellFillPerimeterOverlap”:0.3,“concentricSolidFill”:false,“dynamicTrackingOverPrintPercentage”:0.5,“enableDynamicTracking”:false,“enableVaseMode”:false,“horizontalShellThickness”:1.92,“minimumDynamicTrackLength”:2.0,“minimumGapAreaToProcess”:1.0,“numberOfVaseBottomLayers”:4,“perimeterStartPoint”:{“x”:1000000.0,“y”:1000000.0},“shellThickness”:0.6,“solidFillAngle”:45.0,“solidFillRotationPerSlice”:90.0,“spiralPerimeterTracks”:true,“trackInsideToOut”:false,“trackWidthMax”:0.8,“trackWidthMin”:0.4,“useDifferentHorizontalThickness”:false},“speeds”:{“brimFeedRate_mm_per_second”:20.0,“defaultFeedRate_mm_per_second”:40.0,“externalPerimetersFeedRate_mm_per_second”:20.0,“firstLayerFeedRate_mm_per_second”:30.0,“infillFeedRate_mm_per_second”:40.0,“internalPerimetersFeedRate_mm_per_second”:40.0,“raftBaseFeedRate_mm_per_second”:10.0,“raftTopFeedRate_mm_per_second”:40.0,“shellFillFeedRate_mm_per_second”:40.0,“skirtFeedRate_mm_per_second”:20.0,“supportInterfaceFeedRate_mm_per_second”:40.0,“supportStructureFeedRate_mm_per_second”:40.0,“travelFeedRate_mm_per_second”:120.0},“support”:{“dotExtrusionMultiplier”:70.0,“dotHeight”:0.5,“dotSpacing”:1.0,“dotSpacingRandomness”:0.0,“dotWidth”:2.0,“generateSupport”:true,“interfaceGap”:1,“maxUnsupportedOverhangAngle”:75.0,“minimumSupportedArea”:0.3,“modelSupportXYSeparationDistance”:0.5,“numberOfInterfaceLayers”:0,“perimeterInterfaceStrategy”:“Scanline”,“scanlineDotPattern”:“Paired”,“solidBottomLayer”:true,“solidFillInterfaceStrategy”:“Scanline”,“soluble”:false,“supportCrosshatchFactor”:1,“supportExpansionDistance”:1.0,“supportFillPercentage”:30.0,“supportInterfaceFillPercentage”:33.0,“supportRelAngle”:90.0,“supportTrackWidth”:0.3,“useScanlineBasedDottingAlgorithm”:true},“temperatures”:{“automaticBedTemperatureControl”:true,“automaticFanControl”:true,“automaticNozzleTemperatureControl”:true,“bridgingFanSpeedPercentage”:75.0,“buildPlateTemperature”:70,“defaultFanSpeedPercentage”:75.0,“fanOnDelay”:1,“idleNozzleTemperature”:200,“maxFanSpeed”:255,“nozzleTemperatures”:[200],“overhangFanSpeedPercentage”:75.0,“supportingFanSpeedPercentage”:75.0},“transform”:{“postSliceTranslate”:{“x”:100.0,“y”:100.0,“z”:0.0},“postSliceZRotation”:0.0,“preSliceRotation”:{“x”:0.0,“y”:0.0,“z”:0.0},“preSliceScale”:{“x”:1.0,“y”:1.0,“z”:1.0}}},“dynamicModes”:{“bedAdhesion”:{“raftBaseLayers”:true,“raftBaseTrackThickness”:true,“raftBaseTrackWidth”:true,“raftGap”:true,“raftTopLayers”:true,“raftTopTrackThickness”:true,“raftTopTrackWidth”:true},“infill”:{“infillTrackWidth”:false},“nozzlePriming”:{“skirtTracks”:false},“quality”:{“enableRetraction”:true,“retractionDistance”:true,“retractionSpeed_mm_per_second”:false,“trackThickness”:false,“trackWidth”:false,“unretractionSpeed_mm_per_second”:true},“speeds”:{“brimFeedRate_mm_per_second”:true,“defaultFeedRate_mm_per_second”:false,“externalPerimetersFeedRate_mm_per_second”:true,“infillFeedRate_mm_per_second”:true,“internalPerimetersFeedRate_mm_per_second”:true,“raftBaseFeedRate_mm_per_second”:true,“raftTopFeedRate_mm_per_second”:true,“shellFillFeedRate_mm_per_second”:true,“skirtFeedRate_mm_per_second”:true,“supportInterfaceFeedRate_mm_per_second”:true,“supportStructureFeedRate_mm_per_second”:true,“travelFeedRate_mm_per_second”:false},“support”:{“minimumSupportedArea”:false,“supportFillPercentage”:false,“supportInterfaceFillPercentage”:false,“supportTrackWidth”:false},“temperatures”:{“bridgingFanSpeedPercentage”:true,“buildPlateTemperature”:true,“defaultFanSpeedPercentage”:true,“fanOnDelay”:false,“nozzleTemperatures”:false,“overhangFanSpeedPercentage”:true,“supportingFanSpeedPercentage”:true}},“schemaVersion”:19}

; PATHIO: Pathio necessary settings
G21 ;Set printer to use mm
G92 E0 ;Set Extrude to 0
G90 ; Set absolute positioning
M83 ;Set extruder to relative mode
M200 D0 ;Set printer to treat E as mm, not mm^3)

M104 S200 ; Set nozzle temperature
M140 S70 ; Set bed temperature
G28 W ; Home
M109 S200 ; Ensure nozzle has reached temperature
M190 S70 ; Ensure bed has reached temperature

; PATHIO: Pathio necessary settings
G21 ;Set printer to use mm
G92 E0 ;Set Extrude to 0
G90 ; Set absolute positioning
M83 ;Set extruder to relative mode
M200 D0 ;Set printer to treat E as mm, not mm^3)

; PATHIO: New layer
; layer 1, Z = 0.300000
; PATHIO: Starting new track
; tool H0.300000 W0.300000
; skirt
; indexLimit: 143
G92 E0.00 ; Set the current filament position to E=0.00
G1 E-1.50 F2400 ; Retraction
G1 Z0.10 ; ZHop
G1 X42.10 Y45.00 Z0.40 F7200 ; Travel
G1 Z0.30 ; Undo ZHop
G1 E1.50 F2400 ; Unretract
G1 E0.17 F2400 ; Uncoast
G1 X42.15 Y44.49 Z0.30 E0.0381 F1200
G1 X42.30 Y44.01 E0.0381
G1 X42.54 Y43.56 E0.0381
G1 X42.86 Y43.16 E0.0381
G1 X43.26 Y42.84 E0.0381
G1 X43.71 Y42.60 E0.0381
G1 X44.19 Y42.45 E0.0381
G1 X44.70 Y42.40 E0.0381
G1 X52.53 E0.5862

and this is the piece to print
barrera1_stl_pathio.json (9.8 KB)
barrera 1_gcode pathio2.zip (331.2 KB)

Unless your starting layer is 0.30mm thick, i think something with Zhop is causing your issue.

image

So is the layer size is 0.3mm.
in the quality option there are two options in the first I have assigned 0.4 and the size of layer 0.3 since if under the first option the interior prints it very thin and consumes more material instead with 0.4 filling
It is thicker.
so what balor do I have to put in zHop?

I remember that I have it to 1or 2 since it gave me an error and I could not stamp

Track width : 0.4
Layer height: 0.1

Z-Hop
Z-hop threshold : 0.05
Z-Hop distance: 0.05

G1 E-1.50 F6000 ; Retraction
G1 Z0.15 ; ZHop
G1 X169.36 Y129.14 Z0.15 F5100 ; Travel
G1 Z0.10 ; Undo ZHop

Track width : 0.4
Layer height: 0.3

Z-Hop
Z-hop threshold : 0.05
Z-Hop distance: 0.05

G1 E-1.50 F6000 ; Retraction
G1 Z0.05 ; ZHop
G1 X141.76 Y137.50 Z0.35 F5100 ; Travel
G1 Z0.30 ; Undo ZHop
G1 E1.50 F6000 ; Unretract
G1 E0.02 F6000 ; Uncoast
G1 X141.84 Y136.61 Z0.30 E0.0448 F2400

I do not get it?
I’m thinking of increasing the value of First layer height multipler from 1 to 2

I’m commenting on the progress and modifications.

a cordial greeting to all!
Thanks in advance

Hello again everyone,
Thanks for the feedback.
First of all I managed to reduce the ZHop with these values:
Quality- Global print settings
Track width: 0.4
Leyer height: 0.3
Extrusor Multiplier: 1 ( This value does not influence the decrease / increase of Z-hop and Undo Z-hop )

Z-hop values
Z-hop Threshold : 1
Z-hop distance: 1

Coasting distance: 1
First layer Height multiplier: 0.1 (increasing this value increases the undo Z-hop)

G1 Z0.10 ; ZHop
G1 X123.46 Y158.00 Z0.13 F7200 ; Travel
G1 Z0.03 ; Undo ZHop

I do not understand why when modifying the First layer Height multiplier: 0.1 increases the value of Undo Z-hop.

on the contrary, if I increase the height multiplier of the first layer: 1 increases the value of Undo Z-hop to 0.3 as the Leyer height: 0.3

G1 Z0.10 ; ZHop
G1 X123.46 Y158.00 Z0.40 F7200 ; Travel
G1 Z0.30 ; Undo ZHop

I have to try to print the piece if it happens.

Hello again

I think I have found the error or the cause of not printing well the first layer, after several changes in the values ​​of the Z-hop, deactivating the z-hop, increasing and decreasing the parameters coasting distance and first layer height multiplier getting values ​​mentioned above. I happened to compare with another gcode made with slicer. I noticed that in pathio the value of the first layer is this:
; PATHIO: New layer
; layer 1, Z = 0.300000 <------
M106 P0 S191; Fans turned to 75% of the maximum speed.
; PATHIO: Starting new track
; tool H0.300000 W0.300000
; skirt
; indexLimit: 128
G92 E0.00; Set the current filament position to E = 0.00
G1 X123.46 Y158.00 Z0.30 F7200; Travel
G1 E0.42 F6000; Uncoast
I have calibrated the hot base twice and with another Gcode the first layer prints it perfectly. Fixing that the first layer prints it at 0.14 and then at 0.3.

I have not known to see the option where you can control / modify the value / thickness of the first layer independently of the option Layer height.

how can I modify the value of the first layers and the rest to the thickness previously selected? 0.3.

thanks greetings!!

Who can explain what these values mean: tool H0.120000 W0.300000
and how to decrease the W0.300000 value.

I managed to decrease the value of Z in the first layer by decreasing the option First layer height multiplier to 0.4 and the result is that the separation of the nozzle with the hot bed is lower, puna once achieved this, now I do not extrude well just ejects filament and ends up not printing anything.

a cordial greeting.

Hi @Davidrecio

; tool H0.120000 W0.300000 is only there to help with visualization, and doesn’t impact your printing. You can ignore it.

We don’t currently have a setting to adjust the layer height just on the first layer (without changing the amount of filament that gets extruded). You can cheat slightly by adding the following into your starting gcode:

G92 Z-0.16 ; offset below build plate

This should set your Z axis to think it is 0.16mm lower than it actually is, so your first layer will start closer to the build plate without changing the amount of filament you push out of your HotEnd.

Hello,
thank you very much for your clarification, I will try and report the results

Thank you

1 Like

The Gcode you mentioned in what section I have to add it from the list of printer configuration / Scripts.
I’m not very familiar with modifying or adding codes In a gcode

thank you

Hello again,
Every day I try patio I like more, for its simplicity and comfort in the filleting of the pieces.
As my geeetech printer is a clone of the CR-10 I have tried with the profile that already has included. But unfortunately the same thing keeps happening to me, I do not see how I can lower the height in z in the first layer.
the code that I show next is the recalculation of the parameters of the CR-10 and it continues showing a height in z-0.26 and therefore it does not print, I have also increased the multiplier extrusion values in 1.2 in quality, as well as the I have increased in first leyer height multiplier by 1.3, and do not extrude material.
With the custom profile of my geeetech A30 the same thing happens.
I have tried different firmware: Marlin, Repetier, Makerbot without any visible results.

; PATHIO: Pathio necessary settings
G21 ;Set printer to use mm
G92 E0 ;Set Extrude to 0
G90 ; Set absolute positioning
M83 ;Set extruder to relative mode
M200 D0 ;Set printer to treat E as mm, not mm^3)

M104 S210 ; Set nozzle temperature
M140 S70 ; Set bed temperature

M109 S210 ; Ensure nozzle has reached temperature
M190 S70 ; Ensure bed has reached temperature
G28 ; Home all axes

; PATHIO: Pathio necessary settings
G21 ;Set printer to use mm
G92 E0 ;Set Extrude to 0
G90 ; Set absolute positioning
M83 ;Set extruder to relative mode
M200 D0 ;Set printer to treat E as mm, not mm^3)

; PATHIO: New layer
; layer 1, Z = 0.260000
G92 E0.00 ; Set the current filament position to E=0.00
G1 E-1.50 F2400 ; Retraction
G1 Z0.10 ; ZHop
; PATHIO: Starting new track
; tool H0.260000 W0.380000
; skirt
; indexLimit: 168
G1 X141.24 Y141.30 Z0.36 F5100 ; Travel
G1 Z0.26 ; Undo ZHop
G1 E1.50 F2400 ; Unretract
G1 X141.27 Y140.72 Z0.26 E0.0284 F1200

On the other hand I do not know if I put the Gcode command that I mention @Gabe correctly:
G92 Z-0.16; offset below build plate
I have added it in Scripts / GCode starting script:

M104 S{{ nozzle_temp_0 }} ; Set nozzle temperature
M140 S{{ bed_temp }} ; Set bed temperature
G28 W ; Home 
M109 S{{ nozzle_temp_0 }} ; Ensure nozzle has reached temperature
M190 S{{ bed_temp }} ; Ensure bed has reached temperature
G92 Z-0.16

I’m stubborn and until I get it I’m not going to stop!

A warm greeting and thanks for your patience

Hi!
I don’t see anything in your gcode that would make your printer think it was at Z-0.26. I also don’t see the starting script that you’ve linked below your gcode file. My best guess is that you might have been editing the hardware settings for a printer without activating it, since it sounds like you have two printers downloaded (the generic profile, and the CR-10, right?).

Double check that you’ve got the right printer activated, like this:

As for your printer not pushing filament: is your extruder motor turning at all? If it is, but no filament is coming out, then I would guess you have a clog in your Hot End. If the motor isn’t turning, then you might have forgotten to heat up your printer before printing, or the firmware on your printer might not let you print if you’re at a negative Z axis height. If that’s the case, you’re going to have to change your tactics for lowering your nozzle towards your build plate while not telling the printer it is at negative Z-heights.

A video of your printer not doing what it should be would be helpful, as would an export of your slicing settings (you can send an unhappy face in Pathio, and link to this thread so we know who you are)

Perfect so I’ll do it.
referring to the negative value by eliminating the negative sign has become all blue. I have sent a feedback including the model and the settings.

In case someone happened to him the same these are the steps that I am going to follow next:
Update firmware (if necessary)
calibrate hot bed
check extruder (in case there is a plug)
check parameters in Pathio
review Gcode
To print
I will continue testing values, I will explain the progress.

video of the beginning of the impression
Video.zip (2,8 MB)

Good good good…
After updating my geeetech A30 and calibrate it manually with a sheet that has a thickness of about 0.9 // 0.10 mm.
I have reviewed and compared the parameters and values ​​with other fillers that I have. I launch to print my model and the nozzle is 0.30mm from the base. As I mentioned earlier in my case, lowering the value of the first layer multiplier option, I reduce the value of Z next to the command that I mention @Gabe, so I reprint this time to do more to the hot table.
Eliminate the value G92 Z0.16 and lowering the value to 0.4 in the first layer multiplier with the nozzle to 0.12 of the hot table close enough to print 0.2 mm without problem. But since the filament extusion value is 0.4, it just ejects filament and does not print the first layer well, this is my conclusion and I do not know why this happens?

Marlin firmware chosen but I do not think that influences, in GCode flavor I selected none.

at the moment it is what I have been able to deduce.

a cordial greeting!!

Hello again! I’m still investigating and I discovered this in a Geeetech forum:

" For A30 Users with Firmware version 1.38.59and Level Issue : Fix.
It seems that smartto is not able to accept a level offset of “0”, if you do so it will take +10.
But it will allow any other value, so the solution is quite simple.
go to the manual level menu, set a offset that fits to you (in my actual case -1.55) and save that.
Continue leveling like normal. "

I have not tried it yet, the first thing I’m going to try is putting this Gcode: G92 E0 ; reset extrusion distance, have if I get to zero without having to modify my offset that is “0”.

I’m posting the evolution of my impressions.

Regards

1 Like