Pathio Users

Extruder not heating

When ever I try to print the printer doesn’t heat the head or the bed. It just starts trying to print without any heat on. Do I have to add something in scripts someplace?

Also I am running a duet wifi and wonder what gcode type to select. In s3d all I have selected it standard gcode.

While we wait for the official answer, I’ll provide my best guess based on what I’ve learned…

The temperature settings should be in the start gcode for the printer. There are script variables that can be used to set the temperatures based on the settings in the UI.

For example (from LulzBot TAZ 6):

M140 S{{bed_temp}} ; start bed heating up
M109 R{{subtract(nozzle_temp_0, 55)}} ; soften filament before homing Z
.
.
.
M109 R{{nozzle_temp_0}} ; wait for extruder to reach printing temp
M190 S{{bed_temp}} ; wait for bed to reach printing temp

See https://docs.pathio.xyz/pathio/latest/features/scripting.html for additional information on scripting and the list of variables that can be used.

2 Likes

The default start script took my printer to the home position before heating, but then waited till it had heated the bed and hotend.
Did yours actually move as if it was carrying out the print?

Hi bret,

Would it be possible for you to provide your start and end gcode? As well as possibly the file you wanted to print. That way we can have a look into what’s happening and see if it’s something in the software or in the hardware that is at fault.

Thanks!

Daniel

You guys are right. I was looking at the start script for other printers and saw that they have the temp setting in them. I will copy some parts of other scripts and try those settings.

Still don’t get what gcode flavor I should choose for the duet wifi.

Hi Bret,

Don’t worry about the Gcode flavour, leave it blank.

At the moment, we only support the griffin flavour, used with the ultimaker.

Let us know how you get on!

Daniel

So if I set it to none that would be fine, but at the same time it will end up using griffin flavor?

Also I want to note here that I got the head and bed heating fine now. Just looked at how the prusa i3 mk2 settings looked in scripts and used some of that along with my simplify 3d start gcode.

Hi bret!

Setting to none (blank), it will use the standard flavour of gcode, setting it to griffin, will use the griffin flavour.

Awesome! Do let us know how your prints turn out!

Daniel

Glad you got taht put together. Just so you know, unlike Simplify3D, Pathio doesn’t add in extra heating commands to your print unless they’re in the start code. That might be why you had some trouble even if you copied over your start code from another slicer. We think it gives you a little more control (and we’ll be adding warnings if you don’t have a heatup command to avoid what you had to go through).

As for Gcode Flavour: some printers require special comments at the start (Ultimakers in particular), so we added a Flavour section. If you don’t have an Ultimaker you’re fine using None (and even picking one of the flavours won’t hurt anything).

1 Like