Pathio Users

GSL Precondition Error When Slicing

I have seen this issue described before, except this looks like a different message/cause as it happens while I am slicing & has a different path in the error, though I could be completely wrongPathioFail :slight_smile:

  • **Printer Name:Prusa i3 with RAMPS **
  • Pathio Version:0.5.2 Alpha2
  • Filament Type: PLA

Important Slicing Settings:

LOG

\compileprecodesnode.cpp: 122 }
{ “timestamp”: 2019-03-26T00:56:07.523Z, “level”: “info”, “fields”: Rendering tracks to 3D meshes }
{ “timestamp”: 2019-03-26T00:56:07.523Z, “level”: “info”, “fields”: Generated 0 track segments }
{ “timestamp”: 2019-03-26T00:56:34.789Z, “level”: “info”, “fields”: Loading mesh. }
{ “timestamp”: 2019-03-26T00:56:34.842Z, “level”: “info”, “fields”: Slicing all loaded models }
{ “timestamp”: 2019-03-26T00:56:34.845Z, “level”: “info”, “fields”: Loading model }
{ “timestamp”: 2019-03-26T00:56:34.892Z, “level”: “info”, “fields”: Transforming mesh. }
{ “timestamp”: 2019-03-26T00:56:34.892Z, “level”: “info”, “fields”: Mesh Loaded }
{ “timestamp”: 2019-03-26T00:56:34.892Z, “level”: “info”, “fields”: Starting to slice models… }
{ “timestamp”: 2019-03-26T00:56:35.096Z, “level”: “info”, “fields”: 3D offsetting. }
{ “timestamp”: 2019-03-26T00:56:35.595Z, “level”: “info”, “fields”: Generating support, skirts or brims. }
{ “timestamp”: 2019-03-26T00:56:35.901Z, “level”: “info”, “fields”: Collecting all tracks. }
{ “timestamp”: 2019-03-26T00:56:35.955Z, “level”: “info”, “fields”: {“sliceResult”:{“success”:false,“time”:1062.9168}} }
{ “timestamp”: 2019-03-26T00:56:35.955Z, “level”: “error”, “fields”: GSL: Precondition failure at c:\gitlabrunnerbuilddir\b244d464\1\kernel\fishslice\kernel\src\tasknodes\gcodenodes\compileprecodesnode.cpp: 122 }
{ “timestamp”: 2019-03-26T00:56:35.955Z, “level”: “info”, “fields”: Rendering tracks to 3D meshes }
{ “timestamp”: 2019-03-26T00:56:35.955Z, “level”: “info”, “fields”: Generated 0 track segments }

Whoops!

Can you send along the model you were trying to print and the config for it and we can have a look into it?

Thanks a lot and do let us know if you have any more feedback or suggestions!

Daniel