Pathio Users

Having trouble with the Z Seam

  • Printer Name:
    Geeetech A10
  • Pathio Version:
  • Filament Type:
    Inland PLA White

Important Slicing Settings:

Ender 3 Profile
Print Speed 40 mm/s
Retraction 5 mm
Retraction speed 30 mm/s
Using Linear Advance

I’m getting really great quality prints with Pathio! However, I’m having an issue with a very noticeable Z Seam.


Does anyone have any suggestions of what settings I could experiment with to reduce the seam? I’ve used these same basic settings with Slic3r and S3D and not had an issue with seams.

Sorry about this,

We’ve had this issue for quite a while, and we’re trying to get fixes out for it asap.

We hoped to minimize this in our latest patch by introducing Wiping Distance in the quality tab. This can help mitigate blobs and z-seams.

Let us know how this goes for you!

Do let us know if you have anymore feedback or suggestions!


Thanks for the reply, No apologies are necessary! My experience with Pathio so far has been really pleasant.

I try out the Wiping Distance feature.


We’re looking forward to you letting us know how it goes!


I am having serious issues with the Z seam too, no matter what wipe I try, coast or Z hop the zitting/blobbing to the exterior doesn’t go away. I did experiment with OTT retraction, which resulted in major layer aberration on the shell, and minor alteration to the Z seam sitting or blobbing.
After watching the print, it’s almost as if the printhead is stalling momentarily, and that’s creating teh issue.
Anyone got any settings that work for them??

So I’ve updated to latest 0.5.2-beta and tried out Wiping Distance. I’ve tried values from 1mm to 5mm and I’m not seeing any difference in the seam or print quality. Do I need to try a higher value?

I’ve also tried adjusting coast, retraction, and turning off z hop with no affect to the seam.

Watching the print, I noticed that Pathio prints from the inside out but not in a spiral pattern even tho I have Spiral Perimeter Tracks checked. Each time Pathio finishes a track it leaves a little blob. I can’t seam to correct this with coast either.

24c, what printer do you have?

@Sneakers Sorry just seen this, CEL Robox Dual Material, RBX01 & DIY customised extra height model.
Picture shows default OEM slicer on left vs Pathio on right with ugly zits/blobbing. :slight_smile: This UK company fits heads or hot ends that have needle valves that close the nozzles to prevent ooze, except for the Olsson Ruby SingleX head.

The stringing I can cope with, as a 5ºC downward shift will probably catch this.


BTW I did offset or bias the retraction, equalise the speeds, & then equalise the retraction with retract & unretract scripts, but I am still getting zits on the sides and top layer when using concentric fill. I’ve been busy elsewhere today, so hopefully will have another go tomorrow. I’d like to be able to see the travels in the visualiser, as I think the print is stalling slight every time it completes and starts a track.

Maybe a custom track end and track start option would allow me to correct this. I’ll be trying to fine tune the retraction using some Thingiverse models.

PS Have you checked the Spiral perimeters is checked in Global print settings, Group 1 and you should see it in Model 1 then?


That’s interesting you mention the printhead stalling for a moment @24c, I’ll be trying to see if I can replicate the problem on my printer.

We’re continuing to work and trying to mitigate z seams as much as possible, keep an eye out for out progress!

Let us know if you have any more feedback!


@danwillm I think it was linked to a retract and unretract I had going on, but my Z seams issues are a result of the travel move to the start point, or the end of the track. I’ve just started printing with a 0.8mm nozzle and 0.4mm layer heights, and I can see the correlation in the visual model, and the location of the blobs. :slight_smile: I’ve tried all sorts of coast, wipe and hop etc, but still trying to get to grips with Pathio in a positive way, but using a large nozzle and even bigger layer heights with the default model file is definitely a useful tool.
The stalling is ever so slight now, but it is this causing a momentarily blob. I see it on the start of the first layer. I’ve modded my start code macros, to prime the nozzle better than OEM, and that has improved that one.
Looking at the track end, it’s definitely got a blobby look to it, rather than the previous few mms of linear extrusion, so if I could reduce the extrusions slight before each track end, that would probably eliminate this. Just an idea.


I think z seams are still something that needs to be fixed…

We’ll let you know of the progress.

Thanks a lot for the feedback so far!


@danwillm I totally agree you have a Z seam issue :slight_smile: As just put the same model through two other slicers Simplify3D and OEM, and no Z seam issues at all. The printing order is different too, one has faster jerk from end points to start of new track, and S3D seems to minimise the Z seaming, by extruding in a more seamless way, and any travel motions are minimised within the layer, so the stop starts are minimised. I will have to look at my S3D settings for this printer and see what’s different. :slight_smile: