Pathio Users

How To Specify Left Extruder For Use

  • Printer Name: QIDI X-Pro Dual Extruder
  • Pathio Version: Latest
  • Filament Type: PLA

How do I specify which extruder a print job should use? How do I tell Pathio to use the left (T1) extruder?

Hi wirlybird

We recently posted a video on Youtube detailing how to configure extruders

This can be found via the following link: https://www.youtube.com/watch?v=m-qgVMHzqgo

We hope this helps.

1 Like

Just to add on to what James said, you’re probably also looking for the Materials settings tab (near the bottom of the settings tabs)

I re-watch the video and re-check the materials tab.

I have set up a dual extruder machine (not trying to do an actual dual extrusion) but it will only heat the right extruder. I may be missing something in my start script also.

Will check it out this evening and respond!

I agree that start script sounds like the culprit. We don’t automatically adjust your start script for you when you add more extruders. You’ll want something like this:

T0
M109 S{{ nozzle_temp_0 }} ; Preheat nozzle 1
T1
M109 S{{ nozzle_temp_1 }} ; Preheat nozzle 2
T0

I’ll see about adding that. I build my own start scripts to tune things the way I like. They are however fairly standard.

One thing I have change from a default you guys have is I like the bed to heat and hold before the nozzle starts. Was simply a matter of moving some lines around. Works good now!

Here is my updated script. I have not had a chance to test yet.
Starting at G28 ; Home all axes
is the standard code for the printer. The T1 is just my reminder

;T1 ; switch to left extruder
G91
M83
M140 S{{ bed_temp }} ; Set bed temperature
M190 S{{ bed_temp }} ; Ensure bed has reached temperature

M104 S{{ nozzle_temp_0 }} ; Set right nozzle temperature
M104 S{{ nozzle_temp_1 }} ; Set left nozzle temperature
M109 S{{ nozzle_temp_0 }} ; Ensure right nozzle has reached temperature
M109 S{{ nozzle_temp_1 }} ; Ensure left nozzle has reached temperature

G28 ; home all axes
G1 X0 Y0 F3600 ; move to wait position
G92 A0 B0
G92 E0 ; zero extruder
G1 Y4 Z0.3 F3600 ; prepare to purge
G1 X230 E18 F2400 ; purge

Still selects the right hand extruder.
Here is my script for this printer, QIDI X-Pro, similar to a Creator Pro except Marlin based.
I select T1 materials under materials but it still starts to heat the right nozzle - T0.
Are the left and right identified backwards from what I think?

Also when I look at the gcode it is setting temps for the extruder that are not what I have set and I don’t know where the temps are coming from.

;T1 ; switch to left extruder
G91
M83
M140 S{{ bed_temp }} ; Set bed temperature
M190 S{{ bed_temp }} ; Ensure bed has reached temperature

M104 S{{ nozzle_temp_0 }} ; Set right nozzle temperature
M104 S{{ nozzle_temp_1 }} ; Set left nozzle temperature
M109 S{{ nozzle_temp_0 }} ; Ensure right nozzle has reached temperature
M109 S{{ nozzle_temp_1 }} ; Ensure left nozzle has reached temperature

G28 ; home all axes
G1 X0 Y0 F3600 ; move to wait position
G92 A0 B0
G92 E0 ; zero extruder
G1 Y4 Z0.3 F3600 ; prepare to purge
G1 X230 E18 F2400 ; purge

Patio refuses to use the left extruder. Also I have no idea where the temps are coming from it sets in the gcode.

I’m not familiar with the QIDI X-Pro, but if it’s Marlin based, then it should act how I’m describing below.

Typically in Marlin, you can only heat the active tool. You have to switch tools to heat each one, like so:

T0 ; Left Toolhead
M104 S{{ nozzle_temp_0 }} ; Start heating left nozzle
T1 ; Right Toolhead
M104 S{{ nozzle_temp_1 }} ; Start heating right nozzle

; Wait for heating
T1 ; Switch to Right Toolhead  <--- Not necessary, just for illustration
M109 S{{ nozzle_temp_1 }} ; wait for right nozzle to get hot
T0 ; Left Toolhead (Necessary)
M109 S{{ nozzle_temp_0 }} ; wit for right nozzle to get hot

The code you linked above will set the right toolhead’s temps to the left toolhead because it’s missing the T1 or T0s. If your tools are identified backwards (which makes sense, given what I know about Flashforge Creator Pro) then just swap where I said left and right, if that makes sense.

Hope that helps!

I will work on this but so far nothing has worked.
It insists on heating the right extruder and it is using a temp I have no idea where it is set.
I have both extruders set at 200 but looking at the gcode it sets one at 220 and the other at 210.

I will check the T0 vs. T1 but in S3D T0 is right and T1 is left. Maybe only in S3D?
If I have to manually tell it to use the left in the start script I might as well just set up as a single extruder and have two setups. Kind of a pain but for now it might work.

Nothing is working. It simply refuses to heat the left extruder. The other issue is it is setting the extruder temp and 220 which I do not use anywhere in the slicer. It seems to be stuck on this temp and stuck on using the right extruder.

@wirlybird can you send your full project to us from the feedback tab? It’ll be easier for us to triage what might be going on if we have your full setup in front of us. If you could just paste in the link to this thread when you do, that’ll help us connect the dots. Thanks!