Pathio Users

Nozzle size increases

  • QuickFill using macOS 10.14.3
  • Pathio v5.2Beta:
  • 1.75mm PETG

Just curious, but you would expect Pathio to change the E numbers for the same model (default_pathio.stl), if you were using a 0.8mm nozzle vs a 0.4mm one wouldn’t you with the same printer definition?
I have two different hot ends that reflect their respective nozzle sizes, and for some reason, the E numbers are not changing, which seems a little odd. I have checked the global settings, and Group 1 and Model 1 and they are selecting the larger nozzle size.
At first I thought it was a tool change script issue, so I removed this, but the gcode E numbers are unchanged when I compare the gcode outputs, and after printing the default model out it is seriously “textured” :slight_smile: Do I have to adapt the config files for the printer to see tool changes respected?

UPDATE… I noticed the sliced view still had the same track widths, so I changed T0 to the larger nozzle, and the sliced model was updated with a larger nozzle track etc, so my issue is how do I select T1, as when I slice it is defaulting to T0 and the smaller nozzle. This is despite selecting T1 in the Materials window in Global settings, Group 1 and Model 1.

Hey @24c,

I’m a little confused - were you able to fix your issue?

Sorry about this,

Daniel

No I had to make T1 hot end T0 and then do a toolchange script to lose the wrong reference In the gcode. The issue is if I select T1 in the materials global settings, it extrudes for T0!

@danwillm I don’t understand this at all now, as I have just gone back to the computer opened Pathio, and the extrusion values and head selection is fine. Sorry about this, I’m more than a little confused now. :confused:

Ok not to worry,

Let us know if you have any more issues or feedback and we will be happy to help! :slight_smile:

Daniel

Hi @24c,

If I’m understanding correctly there is an issue regarding the dynamic default for track width not updating when you’ve selected a toolhead with a different nozzle size.

Correct me if I’m wrong but as I understand it this is your problem:

  1. You have a printer with two toolheads, for my example let’s say T0 has a 0.4mm nozzle and T1 a 0.8mm
  2. You Have two models, Model A you want to print with T0, Model B you want to print with T1.
  3. When you select T0 for model A, its trackwidth is intelligently set by our ‘dynamic defaults’ to 0.48
  4. When you select T1 for model B, its trackwidth is incorrectly set as 0.48 also

If I’m describing the problem you’ve ran into, I’m afraid you’ll have to work around it for now by manually setting the trackwidth for any model/role that doesn’t use T0. This is a known problem however so be aware that we will have it fixed at some point!

3 Likes

@HarrisonBrown Thanks for that & the update, and I shall wait for the patch. :slight_smile: